Carbonite Support > Known Issue: The CSSB User Int...

Known Issue: The CSSB User Interface Does Not Open

Summary:

In some cases, you may encounter issues opening the Carbonite Safe Server Backup software on your computer. The CSSB user interface may appear to partially load or will not open at all.

Cause

This issue affects CSSB version 6.4 and newer. There are a few possible causes including an unhealthy installation of Amazon Corretto 8, which is required to run Carbonite Safe Server Backup's user interface. The following are some examples of issues that may affect Carbonite Safe Server Backup:

  • The Amazon Corretto files are damaged, corrupted, or otherwise unhealthy.
  • Registry entries related to Amazon Corretto have been removed or changed.
  • Variables, such as PATH, are not directing to the correct Amazon Corretto files.

Java 8 and Amazon Corretto 8 share many common elements. If both are installed on the same machine, changes made to Java 8 may also affect Amazon Corretto 8.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

Please attempt the following possible resolutions in order:

Confirm the services are running

Please ensure CSSB's background services are running. For issues caused by CSSB services not running, which can sometimes include interface issues, please refer to A Carbonite Safe Server Backup Service Could not be Started instead.

Confirm System Time is Correct

An incorrect system time and/or time zone can cause a number of issues with CSSB, but it is a quick fix. It is worth checking and correcting this first to see if it resolves the issue. Please see this article for more details and instructions.

Update the CSSB Shortcut

Follow the steps below to ensure the Carbonite Safe Server Backup shortcut is targeting the correct executable. Right-click the Carbonite Safe Server Backup shortcut and select Properties. Target should be pointing to \bin\LaunchCLI.exe within the CSSB's install directory. Please note that the install directory may vary, depending on whether the installation is a new install or upgrade and whether the system is 32-bit or 64-bit. The default locations of LaunchCLI.exe are listed below.

For new installs:

  • C:\Program Files\Carbonite\Carbonite Safe Server Backup\bin\LaunchCLI.exe (for 32-bit operating systems)
  • C:\Program Files\Carbonite\Carbonite Safe Server Backup(x64)\bin\LaunchCLI.exe (for 64-bit operating systems)

For upgraded existing installs:

  • C:\Program Files\Carbonite\Carbonite Server Backup\bin\LaunchCLI.exe (for 32-bit operating systems)
  • C:\Program Files\Carbonite\Carbonite Server Backup(x64)\bin\LaunchCLI.exe (for 64-bit operating systems)

If the shortcut does not point to the correct executable, locate LaunchCLI.exe and update the shortcut to point to this executable. Once the shortcut has been updated, relaunch CSSB. If CSSB's user interface opens properly, no further actions are necessary. If the shortcut is targeting the correct executable and the user interface does not open properly, proceed to the next section.

Resolve an Expired Certificate

This issue may also be a symptom of an expired CSSB certificate. For resolution steps, please follow this article: Error Message: "Cloud communication error [CLOUD_ERROR_ExpiredToken]"

If the interface still does not open with any of the solutions in the article linked above, continue to the next section in this article.

Reinstall Amazon Corretto 8

  1. Open Programs and Features in the Control Panel.
    • You can access this from the Start menu (Win + S) or Run... (Win + R) by entering appwiz.cpl.
  2. Locate Amazon Corretto 8 in the installed programs list, then click the Uninstall button and follow the prompts in the uninstall wizard to remove Amazon Corretto 8.
    • Uninstalling Amazon Corretto may prompt you to restart your system to complete the process. If it does, it is recommended to do this outside of business hours to avoid downtime.

    1. After the uninstall completes, launch Carbonite Safe Server Backup, which will detect that Amazon Corretto 8 is missing.
    2. When prompted, click Yes to download and install Amazon Corretto 8.

Once Amazon Corretto 8 has reinstalled successfully, the Carbonite Safe Server Backup interface will open.

Downgrade to CSSB 5.6 (Server 2008-Only)

If you are running Windows Server 2008 (Excluding R2) and the steps above do not resolve the issue, downgrade the CSSB client to 5.6.

  1. Uninstall CSSB.
    1. Do not preserve the configuration.
  2. Install CSSB 5.6.
    1. Within the Backup Dashboard, select Install Carbonite within the section called I want to back up a Server.
    2. From the drop-down menu, select Windows Server 2008 (non-R2) under Legacy Versions
    3. Download your cloud certificate.
    4. Navigate to the knowledge base article linked in the box below the cloud certificate button
    5. Follow the instructions to complete the installation.
    6. Import your cloud certificate using these instructions.
  3. Once you have installed CSSB 5.6 and imported your cloud certificate, recreate your backup sets.

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