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Known Issue: Carbonite Safe Server Backup Service(s) Goes into a Bad State

Summary:

When Carbonite Safe Server Backup attempts to perform some action—such as opening the user interface, saving a backup set, starting a backup, or changing log level—you might receive an error message stating that one of CSSB's services could not be started. However, the error can appear at any time. This article also applies if any of the services is in the Stopped state and fails to start, even if no error is shown within CSSB.

This article does not apply if the errors specify a log on failure. If the error mentions a log on failure, please refer to this Knowledge Base article.

Some of the errors could be as follows:

For new users

  • Carbonite Safe Server Backup Controller could not be started.
  • Carbonite Safe Server Database could not be started.
  • Carbonite Safe Server Backup Controller and Carbonite Safe Server Cloud Controller could not be started.

For existing users

  • Carbonite Server Hyper-V could not be started.
  • Carbonite Server Cloud Controller could not be started.
  • Carbonite Server Backup Controller and Carbonite Server Cloud Controller could not be started.

Cause:

Four services are installed as part of Carbonite Safe Server Backup, depending on your version. They are:

  • Carbonite Safe Server Backup Controller / Carbonite Server Backup Controller, which handles operations on the local system, such as backup and restore. This service does not exist in CSSB 6.5 or later.
  • Carbonite Safe Server Cloud Controller / Carbonite Server Cloud Controller, which handles communication with the cloud, such as upload and download.
  • Carbonite Safe Server Database / Carbonite Server Database, which is a database that CSSB uses to store information about the backups. This allows CSSB to handle many things in an automatic fashion.
  • Carbonite Safe Server Hyper-V Service / Carbonite Server Hyper-V Service, which handles certain aspects of Hyper-V backup and restore. This service will only appear on 64-bit systems that are running Windows Server 2008 R2 or higher and have the Hyper-V role installed.

Occasionally, one of these services may fail to start. If a service cannot start, operations that require the service will fail.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

Unlike log-on failures, this error is generic and can have many root causes. These include, but are not limited to, the following:

  • Insufficient permissions: A service cannot start because the amandabackup / CarboniteUser user doesn't have permission to talk to the service.
    • In some permissions-related cases, the service could not be started error may appear even if the service starts.
    • These are most likely in a domain environment where a Group Policy Object (GPO) may have modified, removed, or changed the default permissions granted to the amandabackup / CarboniteUser user. However, they can occur in any environment.

To begin, locate the affected service(s) in Windows Service, accessible through the Start menu (Win+S) or Run... (Win+R) by searching for Services.msc. Right-click the affected service and select Start to manually launch the service.

If a service fails to start manually, Windows will often provide an error code with more information on what prevented the service from starting.

The amandabackup / CarboniteUser user is granted certain permissions and assigned to several user groups during installation. Each of these groups allows amandabackup / CarboniteUser to perform specific tasks. If the services are running but operations fail with a <service> could not be started error, please verify that amandabackup / CarboniteUser is a member of the proper groups.

For a local amandabackup / CarboniteUser user:

  • Administrators
  • Backup Operators
  • Users

For a domain amandabackup / CarboniteUser user:

  • Local Administrators
  • Backup Operators
  • Users
  • Domain Users

For more information on instances where this happens after upgrading, see Carbonite Safe Server Backup Service (s) Goes into a Bad State After Upgrading.

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