Carbonite Support > Message: "Carbonite Safe Serve...

Message: "Carbonite Safe Server Backup Controller and/or Carbonite Safe Server Cloud Controller Could not be Started due to Log on Failure"

Summary:

When Carbonite Safe Server Backup attempts to perform some action, such as saving a backup set, starting a backup, or changing log level, you might receive an error message. However, the error can appear at any time.

One of the errors could be as follows:

For new users

  • Carbonite Safe Server Backup Controller could not be started due to a log on failure.
  • Carbonite Safe Server Cloud Controller could not be started due to a log on failure.
  • Carbonite Safe Server Backup Controller and Carbonite Safe Server Cloud Controller could not be started due to a log on failure.

For existing users

  • Carbonite Server Backup Controller could not be started due to a log on failure.
  • Carbonite Server Cloud Controller could not be started due to a log on failure.
  • Carbonite Server Backup Controller and Carbonite Server Cloud Controller could not be started due to a log on failure.

Note: This article applies only if the errors specify a log on failure. Otherwise, please refer to this Knowledge Base article.

Cause:

Four services are installed as part of Carbonite Safe Server Backup. They are:

  • Carbonite Safe Server Backup Controller / Carbonite Server Backup Controller, which handles operations on the local system, such as backup and restore.
  • Carbonite Safe Server Cloud Controller / Carbonite Server Cloud Controller, which handles communication with the cloud, such as upload and download.
  • Carbonite Safe Server Database / Carbonite Server Database, which is a database that CSSB uses to store information about the backups. This allows CSSB to handle many things in an automatic fashion.
  • Carbonite Safe Server Hyper-V Service / Carbonite Server Hyper-V Service, which handles certain aspects of Hyper-V backup and restore. This service will only appear on 64-bit systems that are running Windows Server 2008 R2 or higher and have the Hyper-V role installed.

The Carbonite Safe Server Backup Controller / Carbonite Server Backup Controller and Carbonite Safe Server Cloud Controller / Carbonite Server Cloud Controller services log on as the amandabackup / CarboniteUser user. If they are unable to log on, the service will fail to start. Please refer to this Knowledge Base article for more information about amandabackup / CarboniteUser.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

The amandabackup / CarboniteUser user must have the correct rights and the correct password must be provided.

If the service cannot log in using amandabackup / CarboniteUser, the service will fail to start. Open the Windows System Event Logs and check for errors related to the service that fails to start. In most cases, the event will explain exactly why logon has failed.

Two examples can be found below.

The sections below are collapsed. Please click the section title to open / close a particular section.

Example 1: An event indicates that log on failed due to a bad username or password

This indicates that the password for amandabackup / CarboniteUser that is stored in CSSB does not match the password in Windows or Active Directory.

CSSB stores the password for the amandabackup / CarboniteUser internally. CSSB will use this stored password to start the services.

The amandabackup / CarboniteUser password in CSSB is not automatically updated if the password is changed in Windows or Active Directory. The password must be changed manually in CSSB.

Please refer to this Knowledge Base article for more information on how to change the amandabackup / CarboniteUser user password in CSSB. Once the passwords match, the services should start.

The amandabackup / CarboniteUser password is also updated during installation. Therefore a reinstall of the CSSB software will force a password update. Please reinstall CSSB if the password update option in CSSB does not resolve the issue.

  1. Uninstall Carbonite Safe Server Backup from the system.
  2. During the uninstall process, you will be prompted if you wish to preserve configuration information. Say yes.
    1. This will save all of your configuration settings and backup set information.
  3. After the uninstall is finished, re-install CSSB.
    1. If necessary, download the CSSB installer from your account at https://account.carbonite.com.

Example 2: An event indicates that log on failed because amandabackup / CarboniteUser does not have the log on as a service right

The amandabackup / CarboniteUser user is created during installation and is granted certain rights. One of these rights is known as log on as a service. It allows amandabackup / CarboniteUser to function as the log on user for services.

If this right is removed, amandabackup / CarboniteUser can no longer be used as the log on user for the services, and the services will fail to start.

Please grant the log on as a service right to amandabackup / CarboniteUser and start the services manually via the Windows Services Control Panel, Services.msc.

To prevent this from happening in the future, please ensure that the log on as a service right will not be removed by some person or process. Usually, the log on as a service right is removed through direct action of a system Administrator or by an automated Group Policy Object set by a domain Administrator. CSSB itself will not remove the log on as a service right for any reason.

Feedback