Carbonite Support > Message: "Cloud communication ...

Message: "Cloud communication error [CLOUD_ERROR_ExpiredToken]"

Summary:

While attempting to perform normal CSSB operations that connect to the storage provider, a “Cloud communication error”, "CLOUD_ERROR_ExpiredToken", or "CURL_SSL_CACERT" error appears.

Example error:

Cause:

A security certificate expired and needs to be replaced within the CSSB client.

The expired certificate causes failures in virtually any operation that connects to the cloud storage providers. This includes, but is not limited to, the following.

  • Upload to cloud
  • Backup to cloud (but not backup to local disk)
  • Download from cloud (such as during a restore)
  • Importing a cloud certificate

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

This affects the following CSSB versions:

  • 5.6
  • 6.0
  • 6.1
  • 6.2
  • 6.3
  • 6.4, if you installed, reinstalled, or upgraded to this version before June 4, 2020.

Other versions of CSSB are not affected.

Solution:

There are 3 possible solutions. To check if a solution was successful, please perform the “Check cloud connection” test:

  • It is found in the Advanced menu for CSSB 6.0 and higher using the Enhanced UI.
  • It is found in the Cloud menu for CSSB 5.6 using the Classic UI.

Solution #1: Upgrade to the Latest Version of CSSB

Use this solution if:

  1. You are running a version number lower than CSSB 6.4 and
  2. You are not running a legacy operating system such as Server 2003, Windows XP, Windows Vista, or Server 2008

If both statements are true, please upgrade CSSB as described in Updating to the Latest Version of Carbonite Safe Server Backup.

You also cannot upgrade to the latest version if you are using a legacy operating system. Please follow the steps in Solution #3.

Solution #2: Allow CSSB 6.4 to Self-Repair

Use this solution if you installed or upgraded to CSSB 6.4 before June 4, 2020. If you installed or upgraded to 6.4 on June 4, 2020 or later, repair should be unnecessary.

CSSB Version 6.4 will attempt to self-repair the issue twice per day, Sunday through Thursday. At this point, nearly all systems eligible for self-repair have done so.

If the issue does not self-repair, or if you do not wish to wait for self-repair, please take manual action as described below in Solution #3.

Solution #3: Manually replace the certificate file on disk

Use this solution if any of the following is true.

  • You are using CSSB 5.6. Please note that you must perform this any time you install or re-install CSSB 5.6, as the patch file is not included in the main download for CSSB 5.6.
  • Self-repair of CSSB 6.4 failed or has not yet occurred.
  • Upgrade to the latest version is not possible for any reason.

If you meet those criteria, please follow these steps:

  1. Download the patch here.
  2. Extract the contents of the zip file to any location of your choice.
  3. Ensure that CSSB is not performing any backup, upload, download, or restore operations.
    • If it is, please cancel them or wait until they are complete.
  4. Close the CSSB user interface.
  5. Right-click patch.bat and choose "Run As Administrator".
    • You may be warned that Windows protected your PC. If so, please click “More Info” and click “Run anyway”.
    • If you encounter any problems or errors in step 6, please try again without using "Run As Administrator".
    • If you still encounter issues, please perform the steps under Step 6 manually.
  6. Patch.bat will take the following actions, automatically. These steps may be performed manually if you wish to install the patch without the use of patch.bat or if you encounter any problem while running patch.bat.
    • Stop the following Carbonite Server Backup services:
      • Carbonite Safe Server Cloud Controller (aka “ZCBService”)
      • Carbonite Safe Server Backup Controller (aka “ZWCService”)
    • Rename cloud-bundle.crt (found in the \zcb\cert\ folder in the directory where CSSB is installed) to cloud-bundle.crt.orig
    • Place a new cloud-bundle.crt file into the \zcb\cert\ folder.
    • Start the services that were previously stopped.
  7. This patch can be reverted at any time by removing the new files and renaming the original files to the original file name. You must still follow steps 3 and 4 before reverting.
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