Carbonite Support > Message: “some of your files c...

Message: “some of your files could not be backed up due to errors”

Summary:

During a backup, a Carbonite alert appears with the message: “some of your files could not be backed up due to errors”.

  • Support cannot assist with this process however we have included the information in this article to help guide your troubleshooting efforts. If you require further assistance please see a Microsoft technician.

This article applies to:

Carbonite Plans Products Platforms
Basic, Plus, Prime, Core, Power, and Ultimate (Not sure?) Safe and Safe Pro (Not sure?) Windows

Cause:

Microsoft restricts applications like Carbonite from accessing files that exceed 255 characters. As a result, Carbonite cannot back up or restore files when the file location exceeds this limit.

Solution:

  1. Update Carbonite to the latest version.
    • Note: If you are running Carbonite Safe for Windows 5.x, skip this step and proceed to step 2.
  2. Navigate through your file structure and identify any files or folders that exceed this limit.
  3. Copy or move the file into a folder that does not exceed 255 characters.
  4. Delete the original folder that exceeded the limit.

Additional Information:

As a more advanced option, you can use Powershell to create a text file that contains a list of directories that exceed the 255 character limit.

  1. Use the following command:
    cmd /c dir "[directory path to search]" /s /b /a |? {$_.length -gt 255}|Out-File c:\longpaths.txt -noclobber
  2. Copy or move the file into a folder that does not exceed 255 characters.
    • Do not alter any files in system locations such as AppData.
    • If this information needs to be backed up, deselect those files from backup and/or copy them to a location where they will not exceed the character limit.
  3. Delete the original folder that exceeded the limit or deselect it from backup.
    • Do not delete any files in system locations.

After you reduce the long file paths, Carbonite will no longer have trouble accessing locations for backup or restore jobs.

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