Carbonite Support > Message: "Unable to Complete T...

Message: "Unable to Complete The Restore Because One or More Windows Management Instrumentation Queries Have Failed"

Summary:

During a File System restore of a Deduplicated volume, the following error appears:

Unable to complete the restore because one or more Windows Management Instrumentation queries have failed. Please see this knowledgebase article for more information.

Please note that the text of this error is subtly different from another, very similar error. This other error occurs during a Bare Metal Image backup, and it has very different troubleshooting steps.

Cause:

Restore of a Deduplicated volume heavily interfaces with the Windows Management Instrumentation. Restore will fail if WMI calls fail.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

Please note that troubleshooting and repair of WMI cannot be performed by Carbonite Support. As a courtesy, Carbonite has provided some information below.

The Systems Administrator in charge of the system should investigate the health of the Windows Management Instrumentation and repair any problems that may be found.

Carbonite recommends that troubleshooting begin with Microsoft's WBEMTEST.exe tool.

  1. Download and run the WBEMTEST.exe tool from Microsoft.
  2. Attempt to connect to the Deduplication namespace. Default is ROOT\Microsoft\Windows\Deduplication.
    1. Connection will succeed if Deduplication is properly configured. It will fail if not configured.
    2. CSSB will return the error discussed in this knowledgebase article if Deduplication is not properly configured.
  3. Review and attempt to perform all the steps listed here: https://msdn.microsoft.com/en-us/library/jj155466(v=vs.85).aspx.
    1. CSSB must perform each of these steps during a restore of a Deduplicated volume.
    2. If any fail, the error discussed in this knowledgebase article will be returned.
Feedback