Message: "The Backup Has Failed Because We Are Unable to Query Windows Management Instrumentation for Required Information"
Summary:
When attempting to perform a backup of a Bare Metal Image backup set, the following error appears:
The backup has failed because we are unable to query Windows Management Instrumentation for required information. Please see this article for more information.
This article applies to:
Carbonite Plans | Products | Platforms |
Power and Ultimate (Not sure?) | Carbonite Safe Server Backup (Not sure?) | Windows |
Cause:
Bare Metal Image (BMI) backups interface heavily with the Windows Management Instrumentation to gather information about the system. This information is required for full bare metal recovery.
BMI backups require the following WMI Classes to work correctly:
- Win32_ComputerSystem
- Win32_Processor
- Win32_PhysicalMemory
- Win32_LogicalDisk
- Win32_NetworkAdapter
- Win32_NetworkAdapterConfiguration
If the BMI backup is unable to gather any of this required information, it will fail and return the error seen above.
Solution:
You may verify each of those items in Windows Powershell using the Get-WMIObject cmdlet.
- Open a Windows Powershell prompt.
- Type GET-WMIObject <WMI Class>
- Replace <WMI Class> with one of the WMI Classes listed above.
- Example command: GET-WMIObject Win32_Processor
Repeat for each WMI class listed above. Information should be returned for each healthy WMI class and displayed in the PowerShell window.
If information is returned, the WMI Class is functioning correctly.
- Below is an example of a healthy output of GET-WMIObject Win32_Processor.
- PS C:\Users\USERNAME> Get-WmiObject win32_processor
- Caption: Intel64 Family 6 Model 58 Stepping 9
- DeviceID: CPU0
- Manufacturer: GenuineIntel
- MaxClockSpeed: 2592
- Name: Intel(R) Core(TM) i7-3720QM CPU @ 2.60GHz
- SocketDesignation: SOCKET 0
If no information is returned, or if an error appears, then the WMI Class is not functioning correctly.
- These issues must be resolved before Bare Metal Image backups will work.
- Carbonite Support cannot assist with the troubleshooting and repair of the Windows Management Instrumentation. Please contact your Systems Administrator.
- Microsoft offers some documentation on WMI Troubleshooting, such as this example.