Carbonite Support > Search > Message: "[CURLE_SSL_CACERT_BA...

Message: "[CURLE_SSL_CACERT_BADFILE]"

Summary:

During an upload, download, or other similar operations CSSB fails with the following error message: "Cloud communication error [CURLE_SSL_CACERT_BADFILE]".

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Cause:

A certificate file is required to establish a secure connection to the cloud. The name of certificate file is cloud-bundle.crt. If the location of the certificate file isn't correctly listed within the global configuration file, a secure connection to the cloud cannot be established.

Solution:

To resolve this issue, the configuration file named zib.conf will have to be manually updated with the correct location of the certificate file.

The sections below are collapsed. Please click the section title to open / close a particular section.

>1. Locate the Certificate File

The cloud-bundle.crt certificate file can be found in the following location: [installation folder]\zcb\cert\.

The default location is:

For new users

  • On 32-bit machines: C:\Program Files\Carbonite\Carbonite Safe Server Backup\zcb\cert\.
  • On 64-bit machines: C:\Program Files\Carbonite\Carbonite Safe Server Backup(x64)\zcb\cert\.

For existing users

  • On 32-bit machines: C:\Program Files\Carbonite\Carbonite Server Backup\zcb\cert\.
  • On 64-bit machines: C:\Program Files\Carbonite\Carbonite Server Backup(x64)\zcb\cert\.

2. Locate the Global Configuration File

The global zib.conf configuration file can be found in one of the following locations, depending on which version of Windows you are running.

For Windows XP and Server 2003

  • [installation folder]\zcb\conf\zib.conf

For Windows Vista, Server 2008, and newer

New users

  • On 32-bit machines: C:\ProgramData\Carbonite\Carbonite Safe Server Backup\zcb\conf\zib.conf.
  • On 64-bit machines: C:\ProgramData\Carbonite\Carbonite Safe Server Backup(x64)\zcb\conf\zib.conf.

Existing users

  • On 32-bit machines: C:\ProgramData\Carbonite\Carbonite Server Backup\zcb\conf\zib.conf.
  • On 64-bit machines: C:\ProgramData\Carbonite\Carbonite Server Backup(x64)\zcb\conf\zib.conf.
The directory is \ProgramData\ and not \Program Files\. ProgramData is a hidden folder on most machines. To view hidden folders, click this link.

3. Edit the Global Configuration File

  1. Open zib.conf in Notepad or any other text editing program.
  2. Find the line that begins with: ca-info=. There may or may not be a path listed after ca-info=.
    • Example:
      • ca-info=C:\\Program Files\\Carbonite\\Carbonite Server Backup(x64)\\zcb\\cert\\cloud-bundle.crt
  3. If a path is listed, delete it so that only ca-info= remains.
  4. Add the correct path to the current location of the certificate file found in step #1.
    1. Add this path after ca-info=.
    2. You must use two slashes instead of one in the path to your cloud-bundle.crt file.
      • Incorrect Example: ca-info: C:\Path\to\cloud-bundle.crt
      • Correct Example: ca-info=C:\\Path\\to\\cloud-bundle.crt
    3. Be sure to include the name of the file in the path.
      • Incorrect Example: ca-info=C:\\Program Files\\Carbonite\\Carbonite Server Backup(x64)\\zcb\\cert
      • Correct Example: ca-info=C:\\Program Files\\Carbonite\\Carbonite Server Backup(x64)\\zcb\\cert\\cloud-bundle.crt (or ca-info=C:\\Program Files\\Carbonite\\Carbonite Safe Server Backup(x64)\\zcb\\cert\\cloud-bundle.crt)
  5. Save zib.conf and close the file.

Now Open the CSSB user interface and try to upload your backups.

Feedback