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Message: "Carbonite Safe Server Backup Controller and/or Carbonite Safe Server Cloud Controller Could not be Started Because Another Program is Using The Same Port"

Summary:

When Carbonite Safe Server Backup attempts to perform some action, such as saving a backup set, starting a backup, or changing log level, you may receive the following error messages:

  • Carbonite Safe Server Backup Controller could not be started because another program is using the same port.
  • Carbonite Safe Server Cloud Controller could not be started because another program is using the same port.
  • Carbonite Safe Server Backup Controller and Carbonite Safe Server Cloud Controller could not be started because another program is using the same port.
  • Carbonite Server Backup Controller could not be started because another program is using the same port.
  • Carbonite Server Cloud Controller could not be started because another program is using the same port.
  • Carbonite Server Backup Controller and Carbonite Server Cloud Controller could not be started because another program is using the same port
Note: If the error mentions a log on failure, please refer to this Knowledge Base article.

Cause:

Four services are installed as part of Carbonite Safe Server Backup. They are:

  • Carbonite Safe Server Backup Controller, which handles operations on the local system, such as backup and restore.
  • Carbonite Safe Server Cloud Controller, which handles communication with the cloud, such as upload and download.
  • Carbonite Safe Server Database, which is a database that CSSB uses to store information about the backups. This allows CSSB to handle many things in an automatic fashion.
  • Carbonite Safe Server Hyper-V Service, which handles certain aspects of Hyper-V backup and restore. This service will only appear on 64-bit systems that are running Windows Server 2008 R2 or higher and have the Hyper-V role installed.

Occasionally, the Backup Controller and/or Cloud Controller service may fail to start because another program is using the same port. If a service cannot start, operations that require the service will fail.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

This error happens only when another program is using the same port as one of CSSB's services. Port conflicts usually only affect one service at a time. Each of the background services attempts to bind to one or more internal ports, and this fails if the port is already in use.

If another program, service, or process is using the same port, the CSSB background service that needs the port may fail to start.

The sections below are collapsed. Please click the section title to open / close a particular section.

Diagnosing a port conflict

Port conflicts are likely if a single service fails to start. Port conflicts are very likely if the failures are intermittent.

If you suspect a port-related failure, please follow these steps to diagnose the problem:

  1. Open an elevated (run as administrator) command prompt.
  2. Enter the command: netstat -ab > C:\netstat.txt.
    1. You may use any path in place of C:\netstat.txt.
    2. It may take some time for the command to complete. There will be no progress bar in the command prompt.
  3. Open netstat.txt in Notepad.
  4. Search for CSSB's background services in netstat.txt.
    1. Carbonite Safe Server Backup Controller / Carbonite Server Backup Controller will be listed as ZWCService.exe.
    2. Carbonite Safe Server Cloud Controller / Carbonite Server Cloud Controller will be listed as ZCBService.exe.
    3. Carbonite Safe Server Hyper-V Service / Carbonite Server Hyper-V Service, if installed on the system, will be listed as CSBFltSrv.exe.
  5. Note the port number used by each service.
    1. Below is an example output for Carbonite Safe Server Cloud Controller / Carbonite Server Cloud Controller as shown in netstat.txt. The port is listed in bold letters in this example.
      TCP 0.0.0.0:10085 YOUR_HOSTNAME:0 LISTENING
      [ZCBService.exe]
  6. Search for each port number within netstat.txt. If any of the ports are in use by any application other than ZWCService.exe or ZCBService.exe, then there is a port conflict.
    1. Note the name of the service, process, or program that is causing the conflict.

You have two options if you discover a port conflict. You can change the port used by the third-party process, or you can change the port used by the CSSB background service.

Changing the ports used by a third-party process

The netstat command should reveal which process is using the port required by CSSB. In some cases, you can open this program and change the ports. A restart of the application or a reboot of the server may be required.

Unfortunately, Carbonite cannot provide complete information on how to change ports used by programs that are not a part of Carbonite. There are simply too many!

If you cannot change the ports used by the third-party process, you can change them in CSSB instead.

Changing the ports for the Carbonite Safe Server Backup Controller service

The Carbonite Safe Server Backup Controller service requires ports 10080 and 10081, by default. These ports can easily be changed from within CSSB itself.

  1. Open Carbonite Safe Server Backup.
  2. Click the Advanced link in the upper right hand corner.
  3. Within the Global Settings section, click Data Transferring and Networking.
  4. Locate the Backup Port and Restore Port fields.
  5. Change the value to another port of your choosing.
    1. The Backup Port and Restore Port cannot have the same value.
  6. Restart the service in the Windows Services control panel, Services.msc.

Changing the port for the Carbonite Safe Server Cloud Controller service

The Carbonite Safe Server Cloud Controller requires port 10085, by default. The port can only be changed via the registry.

  1. Open the Registry Editor.
  2. Navigate to HKLM\SOFTWARE\Zmanda\ZIB\.
  3. Create a new DWORD registry key named ZCBPort.
  4. Assign any free TCP port to the ZCBPort registry key as a DECIMAL value.
  5. Start the Carbonite Safe Server Cloud Controller service manually from the Windows Services Control Panel, Services.msc.

Changing the port for the Carbonite Safe Server Hyper-V Service

The Carbonite Safe Server Cloud Controller requires port 10090, by default. The port can only be changed via the registry.

  1. Open the Registry Editor.
  2. Navigate to HKLM\SOFTWARE\Zmanda\ZIB\.
  3. Create a new DWORD registry key named CSBFltSrvPort.
  4. Assign any free TCP port to the ZCBPort registry key as a DECIMAL value.
  5. Start the Carbonite Safe Server Cloud Controller service manually from the Windows Services Control Panel, Services.msc.
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