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Known Issue: An "Access Denied" Message Appears On The Backup Page When Configuring a Microsoft SQL Server Backup Set and Cannot Be Dismissed

Summary:

When creating a Microsoft SQL Server backup set, "Access Denied" appears below the list of databases, near a button labelled Check Access or Allow Access.

Cause:

CSSB requires the amandabackup or carboniteuser to have access to your MSSQL server in order to back it up. In most cases, CSSB will attempt to grant this access automatically as described in this Knowledge Base article. On very old versions of CSSB, you must manually click the Allow Access button instead.

Access Denied appears if this access cannot be verified.

The attempts to gain access are performed as the user account that is running CSSB. The same is true when you click the buttons labelled Allow Access or Check Access. Every attempt is made using the account that is running CSSB.

For example: If you open the CSSB user interface while logged in as a user named JohnDoe, then all attempts by CSSB to gain access to MSSQL are performed as JohnDoe.

The Access Denied message will appear if JohnDoe lacks permission to grant or verify the proper rights we require for amandabackup or carboniteuser. This is true even if you manually grant permission to amandabackup or carboniteuser via the SQL Studio Management Studio as described in this Knowledge Base article.

The Access Denied message will continue to appear as long as JohnDoe lacks the permission required to grant or verify the amandabackup/carboniteuser rights.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Workaround:

Although the Access Denied message on the Backup page is safe to ignore in the right circumstances, it can also be overcome by granting sufficient permissions to the account who is logged in and launches the CSSB user interface. In our example above, that account was named JohnDoe. Granting permissions to that account will allow CSSB to verify that permissions were set properly for the amandabackup or carboniteuser account.

Like with CSSB itself, the account must be granted permission to each instance of MSSQL that you intend to back up.

Solution:

The Access Denied message really means "unable to grant or verify that the amandabackup or carboniteuser account has sufficient permission to back up the database." The message doesn't mean that backups will fail; it simply means that CSSB can't verify that the proper permissions are set.

Thus the Access Denied message can be safely ignored if:

  • You have manually granted permission to amandabackup or carboniteuser via the SQL Studio Management Studio as described in this this Knowledge Base article.
    • If you have more than one instance of Microsoft SQL Server installed, you may have to manually add the user account to each.
  • Backups are successful.

Keep in mind that backups will fail with a very specific message if the amandabackup or carboniteuser cannot access the database. This message will specify the instance to which access was denied. If you see such a message, simply add the amandabackup or carboniteuser account to that instance as described in this Knowledge Base article.

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