Message: "Unable to connect to the cloud storage provider. "
Summary:
When attempting a backup operation, creating a new backup set, or when checking the cloud connection, the following cloud connection error appears:
"Unable to connect to the cloud storage provider. Please check your internet connection, then try again."
Cause:
The cloud connection error has one of the following causes:
- Incorrect system time and/or date
- Geo-blocking
- A self-signed certificate
Once the source of the issue has been identified, Carbonite's network traffic can be specifically allowed to resolve the issue.
This article applies to:
Carbonite Plans | Products | Platforms |
Power and Ultimate (Not sure?) | Carbonite Safe Server Backup (Not sure?) | Windows |
Solution:
The sections below are collapsed. Please click the section title to open / close a particular section.
Incorrect System Clock
Please see this article for detailed instructions on fixing your system clock.
Geo-Blocking
Geo-blocking will use IP address information to restrict access based on location. Cloud Connection Errors caused by geo-blocking are caused when CSSB is unable to communicate with Amazon's S3 servers. For more information about the server to which CSSB is attempting to connect, please check the ZIBLogFile.txt file located in the Debug folder in your CSSB Installation Directory. By default, the Debug folder will be in the following location:
For new users
- C:\Program Files\Carbonite\Carbonite Safe Server Backup\Debug\ (for 32-bit operating systems)
- C:\Program Files\Carbonite\Carbonite Safe Server Backup(x64)\Debug\ (for 64-bit operating systems)
For existing users
- C:\Program Files\Carbonite\Carbonite Server Backup\Debug\ (for 32-bit operating systems)
- C:\Program Files\Carbonite\Carbonite Server Backup(x64)\Debug\ (for 64-bit operating systems)
Within the ZIBLogFile.txt file, search for "Error in Cloud Read". The log entry will also be accompanied by the address of the server Carbonite was trying to connect to when encountering the error, as seen in the example below:
- [zcbGetCloudMetaData]::Error in Cloud Read
Cloud permissions not found
CloudController: CheckCloudPermission: Write operation is not permitted on bucket
[zwcCloudGetErrorString]::The Cloud Error is : Too many retries. 'CURL error: Failed to connect to csb-prod-ap-northeast-1.s3.amazonaws.com port 443: Timed out'
Controller: StdErr: CURLE_COULDNT_CONNECT
To resolve the cloud connection error, geo-blocking will need to be disabled or CSSB traffic will need to be manually configured by routing Carbonite Safe Server Backup network traffic.
Self-Signed Certificates
A self-signed certificate indicates the certificate is certifying itself. For CSSB, this is typically caused by an SSL scanner or SSL injection modifying Carbonite's cloud certificate information. The modified data is then rejected by Amazon's S3 servers. For more information about what is causing the error, please check the ZIBLogFile.txt file located in the Debug folder in your CSSB Installation Directory. By default, the Debug folder will be in the following location:
For new users
- C:\Program Files\Carbonite\Carbonite Safe Server Backup\Debug\ (for 32-bit operating systems)
- C:\Program Files\Carbonite\Carbonite Safe Server Backup(x64)\Debug\ (for 64-bit operating systems)
For existing users
- C:\Program Files\Carbonite\Carbonite Server Backup\Debug\ (for 32-bit operating systems)
- C:\Program Files\Carbonite\Carbonite Server Backup(x64)\Debug\ (for 64-bit operating systems)
Within the ZIBLogFile.txt file, search for "self-signed certificate". Please see the example below:
- [zwcCloudGetErrorString]::The Cloud Error is : CURL error: SSL certificate problem: self-signed certificate in certificate chain
Controller: StdErr: CURLE_SSL_CACERT
To resolve the cloud connection error, SSL scanning or SSL injection will need to be disabled or manually configured to allow CSSB traffic by routing Carbonite Safe Server Backup network traffic.