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Known Issue: Backup Failed for Too Many Files

Summary:

Sometimes, a file cannot be backed up. If too many files are unable to be backed up, Carbonite Safe Server Backup will cancel the entire backup run according to the following rules:

  • If the backup contains less than 100 files, the backup will fail if half of the files cannot be backed up.
  • If the backup contains 100 files or more, the backup will fail if more than 100 files fail to be backed up.

A list of the files that failed to backup can be accessed by clicking the blue exclamation point icon in the Details column of the Monitor or Report pages.

Cause:

The most common causes for a file to fail backup are as follows:

  • The Files are Open, Locked, or in-use and Located on a Non-SMB3 Network Share
  • Access to File(s) is Denied
  • The VSS Snapshot Could not be Created or is Deleted During the Backup
  • The Failure Threshold Needs to be Adjusted via the Windows Registry

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

The sections below are collapsed. Please click the section title to open / close a particular section.

The Files are Open, Locked, or in-use and Located on a Non-SMB3 Network Share

The Volume Shadow Copy Services (VSS) are a Windows component used by Carbonite Safe Server Backup to capture the backup of open, locked, or in-use files. VSS snapshots can only be extended to SMB3 network shares. For all other network shares, backup of open, locked, and in use-files will fail.

Note: If you are attempting a File System backup, CSSB will attempt to copy the files even if a snapshot cannot be created.

To resolve this problem, follow one of the steps below:

  1. Install Carbonite Safe Server Backup (CSSB) on the network computer and back up the files locally. If you have a Safe Pro Ultimate plan, CSSB can be installed on any number of computers for no additional charge.
  2. If you are on a Safe Pro Power plan, you can install Carbonite Safe on the network computer and back up the network share files that way.
  3. Or, schedule the backups at a time when file usage is at a minimum.
  4. Or, modify the registry setting to raise the number of failed files to allow CSSB to complete backup of the files that are not open, locked, or in-use.

Access to File(s) is Denied

All backup operations operate under the amandabackup / CarboniteUser user. The amandabackup / CarboniteUser user must have full permissions to all drives to be backed up.

The VSS Snapshot Could not be Created or is Deleted During the Backup

If a VSS snapshot cannot be created or is deleted during the backup, Carbonite Safe Server Backup will continue the backup. However, open/locked files cannot be backed up without the snapshot. These files will fail, in exactly the same fashion as if they were on a network drive.

Most VSS snapshot failures occur because the drive hosting the snapshot runs out of space. Common reasons for running out of space are listed below.

  1. The drive(s) may be full of files generated during everyday use:
    1. Free up some space by moving or deleting excess or unnecessary files.
  2. Temporary files created during a backup can fill up the drive:
    1. Carbonite Safe Server Backup creates temporary files during a backup. If the drive is low on space, these temp files can fill that space up and cause snapshot failures.
    2. Change the Temporary Folder in the Preferences; Advanced menu in CSSB. Then restart the services by clicking Tools; Restart Background Services.
    3. Alternatively, free up some space on the drive(s).
  3. The Windows page file may use up all of the free space:
    1. Windows uses pagefile.sys as virtual memory during memory-intensive tasks.
    2. The actual size of the page file varies, but can often take up many Gigabytes (GB) of space.
    3. Modify the page file properties so that the page file does not fill up the drive. The page file can be reduced in size or moved to another drive.
    4. Or, free some space on the drive(s) in question.
    5. More information about page files can be found in this Microsoft article: http://support.microsoft.com/kb/889654.

Snapshot errors are logged by the system. Refer to the Windows System Event logs and the Windows Application Event logs for additional information.

Also, Carbonite Safe Server Backup log files may reveal more information. Please check in the BackupErrors*.txt files located in the Debug folder in your CSSB Installation Directory:

  • C:\Program Files\Carbonite\Carbonite Server Backup\ (for 32-bit operating systems)
  • C:\Program Files\Carbonite\Carbonite Server Backup(x64)\ (for 64-bit operating systems).

The Failure Threshold Needs to be Adjusted via the Windows Registry

As a final troubleshooting step, you may try adjusting the failure threshold to a value that is larger than the default.

This value can be configured from within the registry:

  1. Locate HKEY_LOCAL_MACHINE\SOFTWARE\Zmanda\ZWC\1.0\ENGINE\.
  2. Create a new REG_DWORD key named FailedFileCount.
  3. Use DECIMAL values and input any value over 100.
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