Carbonite Support > Known Issue: Unable to Select ...

Known Issue: Unable to Select OneDrive Files for Backup with Carbonite Safe

Summary:

You cannot select the original files in the OneDrive locations for backup with Carbonite Safe when OneDrive’s Files On-Demand feature is enabled.

Note: Carbonite Support cannot assist with this process, but we have included the information in this article to assist with your troubleshooting efforts. If you require further assistance, please see a Microsoft technician.

Cause:

When One Drive’s Files On-Demand is enabled, it stores your folders in OneDrive. The files that were originally in these locations are replaced with shortcuts to the OneDrive location. Due to this, Carbonite cannot select them for backup because they are no longer stored on your hard drive like other files. If you were to restore these files, they would be unusable because they are shortcuts to the real files.

Solution:

The following options may or may not be available depending on your version of OneDrive.

The sections below are collapsed. Please click the section title to open / close a particular section.

Option 1: Disable the Files On-Demand Setting

  1. Open OneDrive from your computer through the white or blue OneDrive cloud icon in the Windows taskbar notification area.
    Open OneDrive from your white or blue cloud icon
  2. In the activity center select More, then click Settings.
    OneDrive: Click More / Settings
  3. On the Settings tab, uncheck Save space and download files as you use them.
    OneDrive Settings: Files On-Demand Unchecked

After disabling Files On-Demand, OneDrive will download and store your files locally on your computer and Carbonite will then be able to back them up.


Note: In newer versions of Windows and OneDrive, the settings section is different.

OneDrive Settings: Files On-Demand slider


Files On-Demand can be turned off by "downloading all files" and following the prompts that come after regarding turning off One-Drive and confirming the amount of space downloading the files will take on your hard drive.

Option 2: Configure OneDrive to keep the original files on your device

Navigate to your user profile at "C:\Users\[name]", right-click on the OneDrive folder, and select Always keep on this device.

OneDrive Settings: Files On-Demand slider

If that option is checked for the top-level OneDrive folder, then all data within should be downloaded to your computer, and will therefore be accessible to Carbonite to back up.

Feedback