Carbonite Support > FAQ: How to Install CSSB if th...

FAQ: How to Install CSSB if the Smart Installer Does Not Work?

Summary:

One of the following happens when you run the Smart Installer:

  • It crashes
  • It closes without a trace
  • It throws an error that “Carbonite smart installer is no longer responding”

In many cases, the following error will appear in the Windows Application Event Logs:

NET Runtime was terminated due to an unhandled exception Application log in Event Viewer

Cause:

If the .NET error appears in the Application Event Logs, the issue is due to an unhealthy .NET Framework on the affected server. A healthy .NET Framework installation is required for the smart installer to function.

Smart Installer checks for .NET and installs it automatically if it is not present. However, the Smart Installer cannot resolve some problems caused if .NET Framework is already installed and in an unhealthy state.

An unhealthy .NET Framework is the most common reason for the Smart Installer to fail. However, there may be other reasons.

Solution:

There are two possible resolutions. However, both resolutions are out of scope and cannot be performed by Carbonite Support.

The sections below are collapsed. Please click the section title to open / close a particular section.

Option #1: Repair the .NET Framework

Please repair or reinstall the latest version of the .NET Framework on their system.

This resolution applies only if .NET errors are present in the Application Event Logs.

For convenience, the .NET Framework install files can be found in the following locations:

  • The latest version of .NET Framework is available from Microsoft directly.
  • The Smart Installer includes .NET Framework.
    • Decompression tools, such as 7-ZIP, can be used to extract the contents of the downloaded Smart Installer.
    • Within the extracted contents of the Smart Installer, run NetFrameWorkSetup.exe.

Option #2: Run the Smart Installer on another computer, then transfer the full .EXE file.

Please use the Smart Installer to download the full .EXE file on a temporary system, then transfer it to the system where you wish to install CSSB.

This resolution applies if the Smart Installer fails to run for any reason, including .NET Framework.

Be sure to choose a system that has the same bit level as the one on which you plan to install CSSB. The Smart Installer will always download the installer that matches the system on which the Smart Installer runs.

For example, if the CSSB system is a 32-bit system, you must perform the following steps on a 32-bit system. If the CSSB system is a 64-bit system, you must perform the following steps on a 64-bit system.

If you try to run a 64-bit installer on a 32-bit system the following error will be generated on the system.

  1. Download or transfer the Smart Installer to the temporary system with the same bit level.
  2. Run the smart installer.
  3. Select a download location and make note of it.
    Select the location that Carbonite Safe Server Backup will download the necessary files for the installation or update.
  4. Press Start to begin the download of the .EXE file.
    • The screenshot below shows CSSB downloading the Carbonite Safe Server Backup Setup file on a 64-bit system.
      Carbonite Safe Server Backup downloading and installing components for the installation or update.
  5. Once the download completes, Cancel the extraction.
    Cancel the CSSB Extraction to manually use the .EXE file for installation on another computer.
  6. Open the Download Location and transfer the .EXE file downloaded in Step 4 to the machine you wish to install CSSB on.
  7. After transferring the file, run it to install CSSB.

Please note that, unlike with the Smart Installer, the user will also be responsible for manually downloading and installing any other prerequisites.

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