Carbonite Support > Known Issue: Image File Level ...

Known Issue: Image File Level Restore Wizard Fails to Open in VMWare environments

Summary:

In Carbonite Safe Server Backup (CSSB), the File Level restore wizard for the Image backup set may not open in some VMware environments.

Cause:

On these systems, a quick check of the Application Logs in Windows Event Viewer reveals an App Crash for fileRestore.exe with a faulting module of vm3dgl64.dll. The dll file noted in that crash is the OpenGL video driver included as part of VMware Tools. The application crash that prevents the file-level restore wizard from launching is due to a conflict between the video driver and additional software in Windows that renders our file-level restore window for the Image backup set.

Additional Information:

The driver conflict that causes the app crash can be addressed by disabling 3D Acceleration or by troubleshooting the driver itself.

Method 1: Disable 3D Acceleration

The first process to try is to disable 3D Acceleration. There are different methods to achieve this depending on your VMware implementation. However, regardless of the process used, this requires the VM in question to be shut down to commit the necessary changes.

Method 2: Troubleshoot the video driver

If the first process is not feasible or does not correct the issue, then the remaining process would be to proceed with troubleshooting the video driver. There are two options to address the driver installation.

Option 1: Upgrade/Downgrade VMware Tools

The version of the OpenGL driver included with VMware Tools varies from one version to the next. Simply upgrading or downgrading VMware Tools has a chance of correcting the issue without the VM needing to be taken Offline.

Please note: We suggest upgrading to the newest supported version of VMware Tools for your environment, but if the fails, then downgrading may also work. For example, we have seen customers using VMware Tools 5 be unable to use the file level restore wizard, but upon downgrading to version 4.5 they were able to.

Option 2: Manually change the display adapter for your virtual machine

We confirmed in testing with Device Manager that disabling VMware SVGA 3D under Display Adapters and forcing the use of Windows built-in VGA device can correct the issue.

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