Known Issue: CSSB Restore Fails with "Failed to restore # items because they already exist"
Summary:
Carbonite Safe Server Backup (CSSB) restore fails with "Failed to restore # items because they already exist". This warning is false.
Cause:
After a full backup is taken, if a folder is moved from outside of the selected folder into the selected folder and any change is made within the moved folder, a duplicate is created within the backup archive when the next differential or incremental is created.
Restoring from differential or incremental backups affected by this will cause a warning to occur "Failed to restore# items because they already exist". This warning is false and is merely cosmetic.
A change in this context includes but may not be limited to the following:
- Adding files
- Updating the contents of a file
- Renaming files
- Moving files within the subfolders of the moved folder
Example:
- You select E:\backup to be backed up.
- A full backup is taken.
- You move folder “E:\SomeData into E:\backup”
- E:\backup\SomeData
- A change occurs to “E:\backup\SomeData\anyfile.ext”
- An incremental is taken.
- In the backup, a duplicate record is made for “E:\backup\SomeData\anyfile.ext” in the archive
- Sometime in the future, a restore is done where the affected incremental is used.
- “E:\backup\SomeData\anyfile.ext” is restored.
- The warning "Failed to restore # items because they already exist" is generated.
- This warning will occur when restoring to a location where anyfile.ext is not pre-existing, such as an empty folder.
- This is due to the duplication within the archive itself.
Environment:
- Carbonite Safe Server Backup 6.8
Solution:
Engineering is aware of this false warning and plans to address this in a future release. The current status of this issue is Open.