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Message: "Error 1722: Carbonite Safe Server Backup installation failed."

Summary:

When installing or upgrading Carbonite Safe Server Backup, you may receive the following error message:

Error 1722: Carbonite Safe Server Backup installation failed. Either (1) Backup user "amandabackup / CarboniteUser" could not be created or (2) System is loaded and catalog could not be created in 30 seconds or (3) Security/Anti Virus software is preventing creation of Windows services. Search Carbonite Knowledgebase for more information.

Error 1603 will sometimes appear after you dismiss error 1722.

Note: This article is not intended to fix installations that fail when A conflicting Carbonite product is installed. Please refer to the linked Knowledgebase article if your installation is failing due to a conflicting Carbonite product.

Many tasks are performed while installing CSSB. These tasks include creation of several Windows services, creation of a user account named amandabackup / CarboniteUser, creation of CSSB's backend database, and more. If any of these processes fail, error 1722 will appear.

Cause:

The text shown when error 1722 appears describes the three most common causes for the error:

  • The amandabackup / CarboniteUser user could not be created.
    • Verify that new user accounts can be created on the local machine or domain.
    • If the amandabackup / CarboniteUser user already exists, please delete the user and try again.
  • The server is under a heavy load, causing the installation processes to time out and fail.
    • If your server is under a heavy load, please reduce the load or install CSSB at a later time when the server is more responsive.
  • Interference by security software can block installation of the program itself and/or its services.
    • Common culprits include anti-virus software, anti-malware software, and group policy objects (GPOs) designed to block installation of software and/or services.
    • Please ensure that all Windows updates, including security updates, have been applied. Installing Windows updates often fixes system-level issues that may block installation.
    • Disable your security software and/or whitelist the Carbonite Safe Server Backup install processes.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

The sections below are collapsed. Please click the section title to open / close a particular section.

Error 1722 Appears When CSSB is Installed Following a Failed Installation or Uninstallation

When an installation fails or when CSSB is uninstalled, all of CSSB's related services should be removed by the system.

In some rare cases, one or more of the following services will not be removed.

  • Carbonite Safe Server Cloud Controller / Carbonite Server Cloud Controller
  • Carbonite Safe Server Backup Controller / Carbonite Server Backup Controller
  • Carbonite Safe Server Database / Carbonite Server Database (If the previous installation was of CSSB 4.7 or earlier, this service will be named ZWC-MySQL)

Note: For 64-bit machines running a server OS (Windows 2008 R2, Windows 2012, or higher) that have a Hyper-V role installed, the Carbonite Safe Server Hyper-V Service / Carbonite Server Hyper-V Service will also be running.

When CSSB is installed next, it will attempt to create all of these services. This attempt will fail because the service already exists, and error 1722 will appear.

Leftover files, folders, and registry entries can also result in an error 1722 failed installation.

This particular issue is most common when upgrading from old versions of CSSB to newer versions.

Removing Leftover Services

WARNING: THIS MAY REQUIRE A REBOOT OF THE SERVER

Any and all leftover services from the previous installation must be removed.

  1. Verify if any of the above services are listed in the Windows Services Panel.
  2. Stop any of those services that are running.
    • If more than one is listed, Carbonite Safe Server Database / Carbonite Server Database should be stopped last.
  3. Run the CSSB Installation Cleanup Tool from an elevated command prompt.
    1. To remove CSSB components, download the appropriate file for your operating system.
      1. For 32-bit operating systems - CSBInstallCleanUp_x86.exe
      2. For 64-bit operating systems - CSBInstallCleanUp_x64.exe
  4. Refresh the Services list.
    1. If all of the leftover services are gone, retry your installation.
    2. If any services remain, continue to the next step.
  5. If one or more Services are still present, you must delete the service manually from an elevated command prompt with the command: sc delete [name of service].
    1. Remove any spaces from the service name when using the sc delete command.
    2. For example: sc delete ZCBService.exe will delete the Carbonite Safe Server Cloud Controller service / Carbonite Server Cloud Controller service.
      For a detailed list of all other CSSB services, please review this Knowledge Base article.
  6. There will be one of three responses to the sc delete command.
    1. ACCESS DENIED - The command was not run from an elevated command prompt. The sc delete command must be run from an elevated command prompt. Please try again.
    2. SUCCESS - Refresh the Services list. If the deleted service is still present, a reboot of the system is required to complete the removal of the service.
    3. THE SERVICE HAS BEEN MARKED FOR DELETION - A reboot of the system is required to complete the removal of the service.
  7. Once all left over services have been removed, please retry your installation.
  8. If install is successful you may end troubleshooting.
  9. If it still fails, open an elevated command prompt.
  10. Run the CSSB Installation Cleanup Tool that corresponds to the previous installation of CSSB from an elevated command prompt, and add the -D argument to the end.
    1. For example:
      1. For 32-bit operating systems - CSBInstallCleanUp_x86.exe -D
      2. For 64-bit operating systems - CSBInstallCleanUp_x64.exe -D
      • The "-D" flag is case sensitive. If you see an error after running the command, please ensure the "D" is capitalized.
      • The -D argument causes the Cleanup Tool to remove everything associated with CSSB, including all files, registry entries, services, and the amandabackup / CarboniteUser user. Note: backups on the local disk will also be deleted if they are in the default directory.
        • For example, the default backup directory could be:
          C:\Program Files\Carbonite\Carbonite Safe Server Backup(x64)\Backup_Folder
          However the actual directory depends on where the customer chose to store their backups.
        • Please refer to the article Moving Local Backups to a New Folder if you need to check the location of your local backups or need to move them to a new location.
  11. Reboot the server. A reboot is required to finalize cleanup of components such as registry entries.
  12. Retry the installation.

If the installation of Carbonite Safe Server Backup still fails after following all of these steps, please contact Customer Care. Provide your customer care representative with the ZCBInstallLogFile.txt file, which can be found in the Windows %TEMP% folder.

NOTE: To access any environment variable like %TEMP%, you can simply paste %TEMP% in the address bar of explorer or from the Start->Run command.

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